To prevent the reverse engineering of script apps, many developers encode their program code with tools such as ionCube PHP Encoder to make it human unreadable. This is valid for paid apps in particular, as anybody could possibly use and change the unprotected code without having to pay the required license fees. If you obtain web software encrypted with ionCube PHP Encoder, you can use it without any problems as long as a software tool called ionCube Loader is installed on the hosting server. This loader makes it possible to execute encrypted files and you will often notice it among the prerequisites for a particular script app to be installed. Since the encoded files are already precompiled, they are ordinarily executed quicker and this will enhance the general speed of your site.

IonCube in Cloud Website Hosting

IonCube Loader is a part of all of the web servers which are a part of our cloud hosting platform, therefore whatever the cloud website hosting service that you choose during the signup process, you can activate it from your Hepsia Control Panel. This process is as simple as right-clicking an On/Off button from the Advanced section, so even if this is your first web hosting account ever, you will not need to do anything complex. The very same section allows you to pick the PHP release for your account (4, 5.2, 5.3, 5.4, 5.5), and if you want to switch to some other version, you only need to activate ionCube Loader for it as well. As our platform is rather flexible, you can set some other PHP version and another status of ionCube by using a php.ini file in each domain folder. If this is something you need to do but you do not have much experience, the 24/7 technical support team shall help you very quickly.

IonCube in Semi-dedicated Servers

If you aquire a semi-dedicated server package from our company, you will be able to use any kind of script-driven app which needs ionCube Loader due to the fact that the software tool comes with all servers that are part of our revolutionary cloud website hosting platform. In addition, we support several releases of PHP, therefore if you switch from PHP 4 to 5.2 or 5.3, for instance, you can activate ionCube for that particular release with just a click in your Hepsia Control Panel. Our system will remember your decision, and if you move back to the earlier release of PHP, the tool will already be active. For more experienced users, we also offer the option to pick the PHP version and if ionCube will be active or not for a specific domain without altering the settings for the entire web hosting account. This is done by placing a php.ini file inside a domain folder with a few lines of code.